Crossuite - Problem printing/sending invoices – Incident details

All systems operational

Problem printing/sending invoices

Resolved
Degraded performance
Started 5 days agoLasted 1 day

Affected

Crossuite platform

Degraded performance from 7:41 AM to 7:56 AM, Operational from 7:56 AM to 7:30 AM, Degraded performance from 7:30 AM to 8:10 AM

delta.crossuite.com

Degraded performance from 7:41 AM to 7:56 AM, Operational from 7:56 AM to 7:30 AM, Degraded performance from 7:30 AM to 8:10 AM

epsilon.crossuite.com

Degraded performance from 7:41 AM to 7:56 AM, Operational from 7:56 AM to 7:30 AM, Degraded performance from 7:30 AM to 8:10 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are investigating the inability to print or email invoices to patients.