Crossuite - Slowness in sending emails – Incident details

All systems operational

Slowness in sending emails

Resolved
Degraded performance
Started about 1 month agoLasted about 1 hour

Affected

Crossuite platform

Degraded performance from 3:36 PM to 4:43 PM

crossuite.app

Degraded performance from 3:36 PM to 4:43 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Emails are not sent in full, this is being investigated by our side.